Back to overview
Resolved

Service disruption — Scriptivox Website

Jul 30, 2026 at 3:30pm UTC
Affected services
Scriptivox Website

Resolved
Jul 30, 2026 at 3:44pm UTC

Resolved — Scriptivox Website is operating normally again.

Created
Jul 30, 2026 at 3:30pm UTC

We're investigating a disruption affecting Scriptivox Website. Likely cause: Transcription workers. Updates to follow.