Back to overview
Resolved
Emergency maintenance
Jul 29, 2026 at 11:26am UTC
–
Jul 29, 2026 at 11:29am UTC
Affected services
Scriptivox Website
Resolved
Jul 29, 2026 at 11:29am UTC
Maintenance ended
Affected services
Created
Jul 29, 2026 at 11:26am UTC
Planned engineering work is underway to strengthen the platform. All customer data is safe and untouched.
Affected services